Virtual Keyboard stays on after text entry

Is there a setting to make the virtual keyboard disappear after text entry has been completed?

If not, is there a way to keep the “circle X” at the upper right of the virtual keyboard, so it’s clear that it can be closed? Currently, this close button disappears after a moment of disuse.

@cullenb Whoo, this takes me back. I had a time of figuring these out on of my my XPs awhile ago.

I found that if I put a trigger on the text box that when the Enter key was pressed, that it closed the keyboard/exited editing mode.

As far as the X staying up on the keyboard, I just made sure that the “Allow Close” property was checked on the XP-wide keyboard settings. If the keyboard is up and the user is typing, it tends to stay up. The X disappears when the user presses somewhere else while in text editing mode, but if they touch the keyboard again, it should come back up. Let me know if this helps! :slight_smile:

1 Like

On my text input box, I do have When Enter Key is Pressed > Exit Editing Mode. It’s odd that the virtual keyboard is staying open in this Experience, because it normally doesn’t.

I’ve also got “Allow Close” checked in the Experience Properties in the Keyboard Style dialogue. I’ll keep playing around with it to see if I can get it to behave differently.

Thanks for the quick reply. I really appreciate it.

Hitting the “Return” key on the virtual keyboard makes it hide, so there is that. : )

1 Like

Weird! In that case, I recommend you to open a ticket to Support. Maybe you found a bug…? :bug:

You’re welcome! :slight_smile:

1 Like

Could be . . . I’m going to test it on the unit that’ll be at the event and see what differences if any arise. My workstation is slightly dated and has a personality of its own sometimes. Thanks for the tips!

1 Like

Hi @cullenb,

It depends on what you mean by “text entry has been completed”

  • it means pressing the Enter key, then the default trigger of a Text Input should do the work, if it hasn’t been removed.
  • it means pressing a “submit” button, then you need to add an action on that button that will explicitly “exit editing mode” of your text input(s).

If it’s none of the above, then support sounds like a good option to discuss your case.



Perfect! That makes total sense, I just didn’t see my disconnect. Thank you!