Sketchfab embed using web browser asset


#1

Hello all! I was working on a touch screen interface for an exhibit at my museum where we would display 3-D models. However, the models are much too big to put into intuiface as .objs, so prior to the update I was using sketchfab embed code with the browser asset. That way all the graphics is being handled in browser. However, sketchfab and intuiface both went through an update. Now the 3-D models run painfully slow in the browser asset. Has anyone else done anything like this and do you have any workarounds?

Here is a sample of what I want to view using the browser asset. https://sketchfab.com/models/7fa93e512aad4344ab2d90484e454d56/embed


#2

Hi,

We have tested your provided url in previous versions of IntuiFace and encountered the same behavior. I suspect that changes on Sketchfab might have impacted the manipulation of the 3D object.

Regards,
Mihai


#3

Thanks Mihai. I did figure this out, so I thought I would post some instructions in case anyone else wants to do this. The benefits are that sketchfab is more powerful than the integrated 3D model asset and allows for annotations, but you must have intuiface set up just right for users to interact with the models. While sketchfab will work with a mouse, once the player is running a touchscreen you will run into issues unless you have your settings correctly dialed in.

First off, Your model cannot be larger than 250,000 faces…which is PLENTY for what 99% of people are doing.
Use the http link in the sketchfab embed code as a browser link.
Do not use the entire embed code for your browser asset.
Only use the url that looks like this from the embed code, and you will have a stand alone model.

Browser Asset Settings
Static
Turn OFF pan,zoom, and scroll options
Use the drop down menu and set the asset navigation to map style navigation

I am very certain there are other tweaks that will work, this is just what is working for me.