Remove All and Publish - Excel


#1

I just noticed that when publishing the “remove all and publish” feature does not notice that Excel has links to local content. It will actually remove all of that content and break the links in your presentation

It’d be nice to prevent this to save me some work lol!

  • Agree
  • Disagree

0 voters


#2

Hi Alex,

thanks for reporting this.

Just to be sure, can you confirm that ‘local content’ means ‘content listed in Content Library’ not ‘content stored in same folder as Excel file’ ?

Thanks

Alban


#3

Hi @alban, that’s correct. I had the media files in the content library, and they were referenced in the Excel doc. Let me know if you need anything else!


#4

Hi Alex,

Ok, I understand your issue. For now Composer only checks “static” unused content. By “static”, I mean content that is directly referenced by the Assets in editing mode. Content referenced by Interface Assets (including Excel) or by Actions are not flagged as used.

if you need to reference files in an excel file, I suggest you to put those files in the same folder (or in a subfolder) as the excel file as documented here : http://support.intuilab.com/kb/interface-assets/interface-asset-excel#referencing-media-files-not-listed-in-the-content-library. Those files will not be checked by “delete unused content” mechanism.

Tell me if it helps

Alban


#5

Ok, thanks @alban, that makes sense. So when composer checks for the unused content, it checks all other folders - but skips the Interface Assets folder?

So the two options to get around this would be to publish all content, or move the content referenced by the excel file into the Interface assets folder.

I appreciate the clarifications!


#6

Hi alex,

indeed, the best practice is to move the content referenced in excel file in the the folder containing the excel file (or in a sub-folder if you prefer).

Alban