Player simulation on second Touch Screen

I have a touch screen connected to my notebook and would like to run the player simulator only on the second screen.
What is the least laborious way to do this?
I tried to open the Player on the second screen, but it goes back to the first when it runs through Composer.

Hi there,
I believe all you need to do is open your windows display settings and set your second monitor as your “Primary” screen.

Like I said, I can’t get Intuiface to play the player on this second screen.
Windows configuration i know.

I ended up sharing my project folder and am running it remotely through a player installed on another computer with this touch screen.
It was the most practical way out I found right now.

Hi schumannlabs

I’m not sure how your Laptop is set up, but I have 2 screens set up as extended displays with a taskbar on each screen. If you pin Intuface Composer to the task bar, which ever screen you start Composer using the taskbar, when you hit the play button, the XP will run on that screen. As Sheldon Cooper would say - “Fun fact: if you start Composer in the secondary screen, drag it to the primary screen, you can work on composer in the primary screen, hitting play will run in the secondary screen.”

You can even run 2 instances of composer on each screen with different XPs and have them both play on each screen at the same time. I just tested this but I have not used it extensively, so I don’t know what type of havoc it will cause to windows. I will try this trick the next time I need to test two projects that communicate with each other.

Hope this helps.


This did not work for me as expected.

When starting the experiment nothing happens, it does not appear on any screen.
The solution now is to keep moving Composer from first screen to second screen every time I want to simulate, but that’s not practical.
I would like the Player to run on the second screen always.
And Composer on the first screen always.

I found the Article I used to set this up. I talks about setting up a shortcut.

It is working for me, but you do have to start Composer on the screen you want the project to run on. It’s annoying, but you only have to move it once after it’s open.

@AlexL I did just that and it doesn’t work.
Player starts and does not appear on any screen.