Hide keyboard without exiting editing mode

I’m using an offscreen text input asset to handle a specific task that needs to stay open at all times, but I would like to hide the onscreen keyboard on scene startup and only have it visible when a 2nd onscreen text input is used. I’ve tried the “Allow close” button and then added tap simulations where the close box would be, but that close button isn’t affected by these. I’ve tried using the “Center x,y coordinates” but it only moves the keyboard half off screen, and I really want it completely onscreen when the 2nd onscreen text input is used.

I’ve seen a lot of other people ask to have a way to hide the keyboard temporarily, but I’ve got a unique situation where the typical solutions do not apply. Are there any other techniques I can employ here?

Hello @cullenb,

You are making me think on a Monday, but I have an idea that could work.

To start have a Toggle Button with an is checked trigger that Moves the keyboard as far off scene as possible, which still make it’s visible.

You will then need to change the Scale factor. There is not an action that does this, so you will need to bind the Scale factor of the keyboard to a text asset or variable.

On the is checked trigger change this text/value to 0. Once this is done the keyboard won’t be seen any longer.

Now add an is unchecked trigger to the toggle button give it the action to move the keyboard back to where you want it visible. The Scale will need to be adjusted so you will want to put that back by changing the text/value of the text or variable to 1.0

On the off screen text input add an is given focus trigger and have that check the toggle button. Add a loses focus trigger to uncheck the toggle button.

With it set this way the keyboard will not “show” when the off screen text input it active, but it will show for any other text input.

Here is a link to the experience I created this way.


Ryan, this is some next level problem solving. Great job, sir.

Though I cannot get the keyboard to shrink to nothing, I was able able to shrink it way down to 20px wide with the scale set to 0. I cannot make it go off screen either, no matter how high of a number I enter for the Y coordinate, but I’ve got it very low and about half offscreen. I’ve got the toggle switch controlling two offscreen text assets, one for scale and one for vertical position, and these are bound to the keyboard’s scale and Y axis, so this is way better than it was before.

Thanks for the quick response. I really appreciate it.