Files don't sync between composer and player

how-to
composer
player

#1

Hello,

I’ve placed a .bat file in various Intuiface folders. One of the .bat files is referenced to from an excel asset. The references are correct, it’s a relative path. But when I play the experience from the player and press the icon that represents the .bat file, nothing happens.

Because nothing happened, I checked the experience folder : C:\Users\Public\Intuiface…
All the .bat files in various locations are gone. They didn’t come along when I published the experience. I even tried it with PPT files and I have the same problem.

I did not have this problem before, did I miss something?

Thanks in advance,

Kind regards,

Nicholas


#2

Hi @nicholas.vanbeylen

I would link the .bat files inside the project folder and then you should not have any issues.

Linking them outside of the XP will cause the case you are having.

Regards

Louie


#3

Agree with Louie, that is why I mentioned in your other post regarding the ppt for specific people, to put everything inside the intuiface project folder. Everything outside of it does not get published


#4

Hi Louie,

I’m confused now. I’ve placed the .bat file in the same folder as the interface assets (Excel) with correct references in the Excel sheet. Is this not inside the project folder??

How would I correctly link this inside the project folder?

Thank you for your answer,

Kind regards,

Nicholas


#5

Hi Melvyn,

Thank you for answering again. There’s something I don’t understand. When I create an interface asset (excel sheet) in which I link icons to specific categories. I manually place those icons in:
C:\Users\Nicholas\Documents\IntuiFace\MyExperience2018\Files\InterfaceAssets\References_xlsx

So the icons are right next to the excel and they do come along with the project when I publish. However If I do exactly the same with the .bat file. It’s gone after I publish.

Kind regards,

Nicholas


#6

Hi Nicholas, what is the file path you are referencing in the excel sheet, the easiest I found works is within the References_xlsx folder above create a folder called Files and place your content in this folder.

Now in the excel sheet, the file path would look something like Files\yourfilename.bat

This way when you publish everything goes across.

Regards,
Melvyn


#7

Hi Melvyn,

I did what you suggested as you can see in the images below. In the first image you can see that I created the folder “Files” within the ClassicPresentations_xlsx folder. In the “Files” folder, I have placed the .bat file. Next I created correct references in Excel. The filepath looks like: “Files\Expander.bat”

Then I published my experience and re-downloaded it trough the Player for windows. Again the link didn’t work. So I checked the files as shown in my second image. There you’ll see that it didn’t even bring the newly created “Files” folder with it, nor a .bat file.

Is this normal? Or am I overlooking something?

Thanks in advance,

Kind regards,

Nicholas


#8

Hi, Even if it did not bring in the expander.bat file, it should have definitely brought in the Files folder. Can you send me a the bat file, I will create a test sample XP including the bat file and share it with you, you can then download and let me know if it downloads.


#9

Thank you. I received it!
The .bat file did indeed come along!?

How’s this possible?


#10

I just linked it and made sure the XP saw it, does it solve your purpose ?


#11

I tried what you did in the project you send me, but they still don’t come along. :frowning:
I am now asking help from tech support.

Thank you for all your effort,

Kind regards,

Nicholas


#12

@melvyn_br You might want to explicit what you mean by “I just linked it”?


#13

You should to check whether your antivirus is not automatically deleting it when you download. Since it’s a .bat file, could be your antivirus is deleting it off.

Deleted your downloaded copy, turn off antivirus and download onto the player again and then see if it comes in.


#14

@melvyn_br @nicholas.vanbeylen

To stop your antivirus from detecting the bat. You could convert your BAT to a 32bit exe file.

Regards

Louie


#15

aah… sorry Seb… i mean imported the excel into the XP, created a text box and linked the file path. That way the XP knows the file is there.