Embedding google form with web browser

Hello Everyone,

I’m trying to add a google form to my scene with the web browser asset, but it doesn’t show any content.
I downloaded the flash player as it was written in the asset description, but still nothing. It’s interesting though, I tried to navigate to a news page in the browser and I didn’t see anything by clicking I could start a video on that page. I could hear it, so in theory it was there I only couldn’t see it.

Can anyone help me with what did I do wrong? Or which step I missed?

Thank you!



Would you mind opening a Support Ticket and sharing your Experience with Support Team? It would make things easier if I could take a look at your Experience and see what you’ve built.


Thank you Helen,

I read a bit more and I saw it won’t render in remote session, and recently I’m working through my Mac on my brother’s windows during the lockdown. I opened the experience directly on his computer and it worked.
Sorry for the early cry for help. :slight_smile:


1 Like

Hi Zoltan,

Okay! Thanks for the update!

Enjoy the rest of your day!