Do Not Show Keyboard on Text Input - reboot

Back in 2016, ## CullenB asked if it were possible to disable the virtual keyboard when using the TEXT INPUT control. I am petitioning/requesting for the same functionality or a work around.

I have been told to set the scale factor of the scene keyboard to 0.0 and the location at 0,0, however this still allows the very small keyboard to be interact-able to the user.

Also, deactivating the “visible to interactivity” property prevents the text input field from receiving input, so this wont work either.

My use case is as follows: The text input is receiving input from a bar-code scanner. Therefore no keyboard is needed or desired.

Is there anything I can do to make this keyboard go away or appear completely off screen?

Pretty please?
-Frank Yoder

Hi Frank,

Won’t this help?

v6.3.15

6-Jun-2019

Enhancements:

  • Prefer the use of a physical keyboard? Now you can hide the Intuiface virtual keyboard whenever a Text Input Asset or field in the Web Browser Asset is selected. Do this using the Composer/Player Settings panel. (It’s a good option if you’re worried about accessibility - i.e. encouraging all to participate, even those who cannot reach the screen.)

Details here: https://support.intuiface.com/hc/en-us/articles/360007183952-Composer-and-Player-Settings#understanding-the-configuration-options

Regards,

Alex.

Thanks for the suggestion and trying to help me.
Unfortunately I need the virtual keyboard to be present on other text input fields. One other input text usage in this experience is where I am asking for the user’s email address so that I can send them an e-receipt.
What is needed to solve this problem is the ability to turn the virtual keyboard off for an indivudal text input control instance. If this option to have the keyboard appear was a property of the text input control, then my problem would be solved.
Or if the keyboard could be placed at an X,Y screen coordinate that was out of sight, then I would be able to place it out of view and out of reach of the user. I can do this with all other controls. It would solve my problem if I could do this with the keyboard also.

Hi @Frank.Yoder ,

Sorry for the late reply.
Did you try to move the keyboard to a position out of the viewport when the desired trigger occurs?
For a Barcode Scanner, it could be “text is updated” I guess?

I did some test with “is given focus”, moving the keyboard to Y=-800

That’s how it behaves:

Hope this helps.

Regards,

Alex.

1 Like

Alex, Thanks for this solution to my problem. Although I can not SET the original appearance of the keyboard to be OFF the screen, MOVING it off the screen as you suggested, works great. That satisfies my need. Thanks so much!

2 Likes