Animation actions do not work in Player


#1

Hi all,

I wonder whether anyone else has experienced this: Basically I have a trigger that is associated with several actions (>10) in a staggered way. When I preview the animations in the timeline everything looks fine. However, in Player my animations after a certain point do not work. I cannot think of a reason why this would be and this is the first time I have encountered a problem like this (the issue is not related to other objects being on top of the ones that are supposed to be animated).

Many thanks
Deni


#2

Hi Deni,

This sounds like a bug. I suggest you to open a new discussion on our support site: http://support.intuilab.com/discussions/problems


#3

Any update on this post? I am having a similar issue.


#4

Hi Ben,

As I said to Deni, this sounds like a bug. I recommend you to open a new discussion on our support site so we can investigate your issue : http://support.intuilab.com/discussions/problems

Alban


#5

Since I did not see this topic posted in “problems”, I will address how I fixed it here.
I had the same issue with hot buttons on a large object that were supposed to pulse in a staggering way 6 times each upon entering the scene and then repeat the same action after the scene has been idle for a certain number of seconds. I found that not all of the hot buttons would repeat, especially if you had clicked on them already. There was nothing in my triggers that indicated a reason for this, since I was only changing opacity and not hiding them. They were all identical, except for where they fell in the timeline (fractions of a second differences). Also, the player was freezing up the first few times after I upgraded.
I solved these issues by resorting to animated gifs. Each hot button is an animated gif, instead of making the software do the animation. It now runs faster and has totally reliable animation.