Video gallery- Scenes VS loading everything in one scene


#1

Hi,
I was wondering if anyone had any tips for optimizing a video gallery I’m working on. It’s working ok but I’d like to make it sexy. Here’s a video of what’s going on and more details below. (in the video, I’m showing the actions I use for the workaround, then I click on a video using those actions- then for reference I click on a video I set up using different scenes) https://www.dropbox.com/s/ys3sicw7are56tl/IMG_6788.MOV?dl=0

So to clarify:

A: I switch away from the main menu scene, to another scene containing the video you clicked on. There is a 2 second delay or so which I guess is just how intuiface transitions between scenes. Then upon return to the menu it comes back buffering out of focus and finally loads. Pretty clunky :frowning:

B: My work around is to place an empty video asset on the main menu scene and hide it. Then show it when a movie is triggered and load that file into the blank movie asset. This works great but there’s that PLAY BUTTON (or in this case REWIND BUTTON) that shows up when you tell a video to play through triggers and actions.

Does anyone know if you can get rid of that pesky play button? I guess it’s not part of the “show controls” option?

People I’ve tested this on fire a video then immediately try to touch that button which (according to my minimalist interface design) closes the video and goes back to the main menu.

Any hacks around this?
thanks,
Carson


#2

Hi @carson,

First, you can remove the “play icon” on the video by unchecking the show usage animation property of your scene. See documentation here.

Second, seeing your scenario, staying in the same scene to display the menu / playing video is the right thing to do to avoid the scene transition time. I don’t know if your “video wall” is made of videos or simple images, but using images would be a nice way to optimize the scene.

Since your video covers the entire scene, you don’t even need to hide the “video wall” behind. Just show/hide your video when playing it / stopping it.

Seb


#3

thanks very much, my main concern was getting rid of those icons and “show usage animation” did the trick.

Carson