Images Randomly Blurry


#1

Just recently, I’ve noticed that images are randomly blurry… If I switch between scenes sometimes the images will redraw perfectly, sometimes they’re blurry again after a while. Has anyone come across this issue, recently? Are there any workarounds? This was happening in both the preview player from within Intuiface Composer and the standalone player on multiple machines. Any help is appreciated! Thanks!


#2

@nnarczewski

What are you image sizes? and png or jpeg i have had this before but never found a solution.


#3

My image size (in this case) is 1028 x 578px, PNG.


#4

I have been able to overcome this in the Player by performing a “run-through” : running through all scenes of the experience “back and forth” in order to get the experience “limbered up” and accustomed to opening and closing content. After one run through, everything usually operates as expected.


#5

I’ve tried that approach, in the hopes that it would keep that (high resolution) image in the cache, but it doesn’t seem to help… We’ve even seen images come in high-res, and change to low-res as we watched it, right before our eyes.


#6

Hi Nickolas,

I recommend you to open a ticket on our Support Site so we can investigate.

Support Team will probably ask you to share your XP (if possible, reduced to the non-working part) with xp-for-support@intuiface.com so you may want to do that just after creating your ticket.

Regards,

Alex.


#7

Hi Alex,

It seems that it is a re-draw issue with PNG files. Unfortunately, I had to find a workaround, so I really can’t supply the experience.

But, I just thought I would let you know.

The JPG replacement images seem to be working properly.

Thanks,


#8

I too am having this issue. The pngs/jpegs I am using are really high resolution, but in the game I am developing I have had to downsize them in Intuiface (physical size in the game, not resolution). Some go blurry, some are crisp, some change as I move them.

What was the workaround ? Any suggestions?

Thanks!


#9

Hi @mike.r,

As @Alex suggested above, contact our support team and share your experience with xp-for-support@intuiface.com so they can analyze your issue.

Thanks

Seb