Add audio to button


#1

When a user releases or presses a button, I would like a brief audio file to play (i.e. a 0.2 sec click sound) before transitioning to a new scene.

I can achieve this through the use of Triggers and Actions, however the audio only plays 50% of the time. I want it to work 100% of the time.

Even if I delay the scene transition by 1 sec or more, the audio file still won’t play 100% of the time.

Example:
When BUTTON is pressed, PLAY audio file named CLICK with start time of 0 seconds.

Does anyone know how to achieve this?
Thanks in advance for your time and support. I’m new to Interface and I’ve been able to tick off everything I’d hoped the software could accomplish except this audio problem.


#2

I partially resolved the issue by updating the MP3 file itself. Using Adobe Audition, I changed the duration from 0.2-seconds to 1-second in total by adding 0.8-seconds of silence. For reasons unbeknownst to me, it works nearly all the time.

HOWEVER - it doesn’t work at all in the following instance. When entering a new scene, none of the buttons will play audio until 1.5 to 2-seconds of time have elapsed.

Has anyone experienced this and if so, found a workaround?


#3

This has been resolved. I added the audio to an ‘Experience Layer’ so I could easily call the audio at any time without it having to load into memory upon entering each individual scene.

Thanks for the Intuiface Support team for their assistance.


#4

Thanks @randall for updating the community of the results you got from our support team.
We’ll work on a knowledge base article to give more details about this scenario.

Seb